Server requirements

Make sure all requirement meets before installation.
  • 01. PHP version and Php Environment

    • PHP version must be >=8.0. Make sure to all extensions are available.

    php_version
  • 03. Php option

    • Make sure below options are enabled.

    php_option
  • 04. Mysql version

    • Minimum requirement for Mysql version is 5.6.

    • Application won't work properly without recommended mysql version.

    mysql_version
  • 05. Folder Permission

    • Please check folder permission meets with requirement.

    • .env

    • config/gain.php

    • bootstrap/

    • bootstrap/cache/

    • storage/

    • storage/logs/

    • storage/framework/

    folder_permission
    • Symlink permission must be enabled.

    • If symlink() is disabled then you will not be able to change any images on the application (Profile picture, icon etc..).

    • You might get response "symlink() has been disabled for security reasons". In this case please contact with your hosting provider to enable it.

    • Alternatively if service provider denied to enable symlink then you can use cron job from you cpanel.

    • Create a cron job using this command "ln -s target_link storage_link" (need to replace target_link and storage_link what you get from the response).

    symlink_permission